网站地图985论文网
主要服务:硕士论文,硕士论文写作、论文发表、论文修改服务

局域网的组建与应用

来源:985论文网 添加时间:2020-05-12 10:48
摘要
随着现代信息技术的进一步发展,局域网技术特别是虚拟局域网技术的应用给人们的生活和工作带来了极大的便利。虚拟局域网的应用不仅可以大大提高网络通信技术的管理,而且可以提高网络信息的交换速度,从而保证网络通信的安全可靠。如今,随着计算机网络的飞速发展,各种网络产品层出不穷,产品更新的频率端口正在加速。企业对网络的依赖已从原来选择网络设备的模式转变为企业局域网建立战略的需求,可以为企业提供高效、稳定、畅通的网络环境,满足企业的一切需求。因此,在全球电子信息和网络快速发展的环境中,无论是从总体趋势还是从企业自身的商业利益出发,建立内部局域网是企业的当务之急。因此,如何合理、安全、高效、广泛地建立企业局域网是一个值得我们研究的问题。
关键词:局域网;VLAN;STP配置
 
前言
在信息技术时代,随着计算机技术的发展和网络应用技术的不断发展,人们对计算机通信技术的要求越来越高,从而促进了局域网技术的创新和发展。虚拟局域网的出现极大地促进了网络通信技术的管理,不仅提高了网络信息交换的速度,而且保证了网络通信的安全可靠,为人们的工作和生活提供了方便,促进了人们之间的共享。因此,虚拟技术的应用对计算机局域网的发展具有重要意义。因此,从促进VLAN发展的角度,笔者将重点研究VLAN的构建和应用。
1  虚拟局域网的相关理论
1.1虚拟局域网的概念
虚拟局域网是一种流行的虚拟化技术.该技术使真实的计算机设备和用户在进行相关的网络操作时不受空间位置的约束,并通过潜在的逻辑将它们连接起来,从而可以携带类似于同一网段之间的通信。沟通交流网络流量信息。
1.2虚拟局域网的优势
在虚拟化技术的应用中,局域网技术的改革给计算机网络的使用带来了极大的方便,主要体现在以下几个方面:
为了降低计算机局域网的管理成本,传统局域网技术将受到用户的时间和空间的限制,而局域网将限制用户的网络通信设备,但是,通过虚拟局域网技术的应用,用户设备的使用不会受到空间因素的限制,主要是因为它每个子网都有一个独立的广播域,从而实现网络信息的相互交换,从而有助于降低用户的使用成本。
为了保证网络通信的安全性和可靠性,传统局域网需要通过端口进行通信。因此,很容易受到病毒的攻击,特别是在信息交换和资源共享的过程中,很难保证用户网络使用的安全性。虚拟化技术在局域网中的应用不仅可以提高网络的安全性,而且可以使网络彼此无法访问。虚拟化技术可以实现网络的划分。通过将其划分为多个网段,每台计算机都可以访问网络,从而为计算机使用的安全性奠定基础。
随着计算机网络接入速度的提高和虚拟技术在局域网中的应用,可以利用自己的广播域实现不同的计算通信,有利于提高网络通信速度。基于上述优势,虚拟化技术的应用对计算机局域网技术的发展起着重要的促进作用。
1.3计算机虚拟局域网组建的意义
虚拟局域网(VirtualLocalAreaNet work,VLA N)采用先进的虚拟化技术,将局域网逻辑地划分为若干个虚拟网段,实现各网段之间的数据交换。用户和设备在使用VLAN时不受时间和空间的限制。虚拟化技术的应用极大地促进了局域网技术的创新,给计算机网络的使用带来了许多方便。其优势主要体现在三个方面。一是降低计算机局域网管理成本。传统局域网技术不仅受到用户的时间和空间的限制,而且受到局域网的限制。VLAN技术的应用不仅使每个子网都有一个独立的广播域,而且使用户设备能够不受空间限制地使用。通过路由器接收子网信息,可以交换网络信息流,从而促进降低用户计算机局域网的使用成本。二是为人民网络通信安全可靠提供保障。当传统局域网通信时,所有信息都需要通过端口。因此,信息交换和资源共享容易受到病毒的攻击,无法保证用户的网络安全。虚拟化技术在局域网中的应用可以提高网络安全性。在虚拟局域网中,计算机无法相互访问。虚拟化技术将网络划分为几个网段。每台计算机都有网络访问权限,从而保证了计算网络的安全性。三是提高计算机网络接入速度。虚拟技术在局域网中的应用将局域网划分为广播域,使不同的计算通信具有各自的广播域。因此,用户在与网络通信时,可以减少广播域中无用数据的传输,从而提高网络通信速度。从这个角度看,虚拟化技术对计算机局域网技术的创新和发展具有重要意义。
2  虚拟局域网的实现
2.1实现原理
在VLAN的实现过程中,首先,VLAN交换机从工作站接收相关数据,并通过自己的数据分析功能检查一些数据信息。之后,通过将虚拟局域网与数据库中的信息进行比较来监测数据的流量。在VLAN中,如果用户在使用时希望向特定的设备发送特定的数据,则在此过程中将相应的VLAN标识或相关标签附加到发送的数据上。根据VLAN的标识和目的地址,它可以通过VLAN交换机将数据转发到统一局域网的适当目的地。当然,如果数据没有发送到局域网设备,就不会有相关的局域网标识符。
2.2实现方法
在交换机上实现VLAN有四种方法。一是基于端口划分VLAN,即基于以太网交换机端口划分VLAN,方便成员的定义,这也是目前应用最广泛的方法。另一种是根据MAC地址划分VLAN,即根据每个主机的MAC地址划分VLAN,并根据主机的地址配置成相应的组,可以在用户的物理位置移动。不需要重新配置VLAN;第三,基于IP多播划分VLAN。多播是VLAN。事实上,VLAN技术扩展到广域网,但在实践中很少使用。第四,根据网络层划分VLAN,根据各主机的网络层地址或协议类型,可以直接识别VLAN,有效地减少网络流量,提高网络管理员的工作效率。
3  计算机虚拟局域网的组建
3.1组建原则
局域网的建立需要坚持分阶段统筹实施的原则,坚持公开,实用,推进的原则,做到统筹规划,逐步实施。在构建VLAN之前,需要绘制开关柜配置的结构图。根据以上虚拟局域网实现方式,选择最适合VLAN的端口,每个端口都要接入VLAN组成的子网,实现良好的对接。通过本计划,有利于实现VLAN端口的配置要求。其次,为了简化相应的工作,需要尽可能减少子网的数量。如果子网数量较大,难以合理控制,必须做好定期数据恢复工作,以便系统恢复到默认设置。最后,有必要找出端口是否需要标记,如果需要,它也必须符合IEEE802.1Q标准。
3.2虚拟局域网的划分
建立计算机虚拟局域网的第一步是确定局域网分区的目标。虚拟局域网的划分与虚拟局域网的运行密切相关,包括IP子网划分、协议划分和端口划分。在VLAN技术的实际应用中,可以根据实际的网络需求进行合理的选择。在固定物理位置和计算机数量的前提下,可以采用静态端口划分方法进行VLAN划分。对于更多的计算机,可以选择IP网络划分方法进行VLAN划分。为了使计算机局域网的运行更加稳定,需要为计算机网络提供良好的环境,以提高虚拟局域网的通信效率。
3.3虚拟局域网的配置
虚拟技术在计算机局域网中的应用在实践中起着重要的作用。在这一过程中,虚拟局域网络的配置起着重要的作用。在构建逻辑子网的过程中,VLAN依赖于物理网络作为基础。因此,网络适配器的管理在解决子网之间的关系中起着重要的作用。在计算机上安装VMware Work station增强了计算机网络通信适配器的管理,并使计算机与虚拟局域网之间能够进行信息交换。VLAN的物理配置有三种,桥接模式,NAT模式和主机专用模式。桥接模式是利用虚拟桥接网络,使计算机网络信息能够相互通信。配置图见图1。
 
图1  桥接模式虚拟局域网配置图
所谓NAT模式,就是在网络设备中虚拟局域网的应用下实现计算机连接。这种模式可以促进虚拟网络的DHCP服务管理。配置图见图2。
 
图2  NAT网络虚拟局域网配置图
在网络交换机中,直接应用虚拟局域网实现虚拟网络信息的交互,这就是所谓的主机唯一模式。配置图如图3所示。
 
图3  仅主机虚拟局域网配置图
3.4虚拟局域网网络设备
在网络交换机中,直接应用虚拟局域网来实现虚拟网络的交互,网络设备的选择直接关系到整个局域网的运行和管理。适当的VLAN设备不仅可以提高VLAN的信息交换速度,而且可以保证VLAN的运行。在选择VLAN设备的过程中,应满足VLAN要求,如参考设备的型号、品牌和参数,以确保VLAN交换机的稳定运行。
3.5组建步骤
在具体步骤中,应考虑网络体系结构、网络拓扑和基本设备的选择以及今后的维护和更新。由于VLAN是逻辑子网,因此仍然依赖于所使用的特定物理网络,即在选择相关网络设备时,需要考虑它们对所使用的局域网技术的适应性。在虚拟局域网(VLAN)中,通常采用路由器和三层交换机进行信息交换和传输,从而有效地控制用户数量。具体步骤可分为三个步骤。第一步,根据实际使用的计算机总数,办公地理因素和总体网络布线总体规划,制定切实可行的总体规划。应注意的是,应分别在计算机的核心服务器和防火墙中建立一个VLAN段,并根据实际情况进行下一步的规划和安排。第二步,根据端口、协议、IP子网和MAC局域网划分技术的不同相关性,以及各自办公室使用的需求。例如,对于中小企业来说,办公室使用的计算机数量和空间和位置因素变化的可能性相对较低,因此可以优先采用基于端口的静态虚拟局域网分区技术。主要过程是根据任意端口设置VLAN端口的成员,然后将数据从该端口转发到指定的LAN数据包。第三步,解决路由器和ACL接入配置相关问题。由于虚拟局域网技术可以使计算机服务器设备之间的高效通信突破空间位置的限制,而局域网通信的其余部分需要相关管理人员的许可和批准,当需要启用和禁用第三层的根来建立局域网时,请根据实际情况进行切换。第四步,根据实际设计方案和指挥参数,选择合理的网络设备。根据不同品牌和型号的交换机的不同性能和配置,有必要对相关配置进行针对性的安排,以区分局域网配置参数和语法命令。
4  计算机虚拟局域网的应用
4.1局域网内部的局域网
VLAN技术的应用已广泛应用于各个领域。由于企业和用户对VLAN的要求不同,为了满足VLAN的不同要求,有必要将局域网分成几个独立的局域网。对于一些大型企业来说,计算机设备的固定数量和物理位置直接建立适合企业网络通信的虚拟局域网络。当企业建立局域网时,可以在每一层建立单独的虚拟局域网,局域网和其他局域网是独立的。由于访问限制,计算机无法为其他目的访问端口。由于空间中移动物理位置的网络通信问题,可以通过建立内部虚拟局域网来解决。例如,虚拟局域网络技术是目前校园网络管理的主要方式。只要有属于变更后的局域网和登录名的账号,就可以在虚拟局域网的覆盖范围内实现网络通信。因此,为了使人们的生活和工作更加方便,我们可以建立VLAN的内部局域网,这是所谓的主机模式。配置图如图3所示。
4.2网络的共享访问
随着计算机网络通信技术的飞速发展,人们对计算机和互联网的依赖越来越多,虚拟局域网络的使用要求也越来越高。在这种环境下,网络共享接入技术诞生了。在共享的网络通信环境中,用户根据自己的需要使用网络,称为虚拟局域网网络共享。例如,共享网络平台在我国大型企业中得到了广泛的应用。员工可以通过连接到企业的共享网络访问互联网。此外,继电器技术的辅助应用是VLAN技术应用的主要部分。为了实现区域内网络通信的共享,用户可以通过中继调整路由器。目前,我国虚拟局域网的网络共享技术存在隐私披露等诸多不足。因此,为了使我国计算机虚拟局域网络更好地发展,我们应该重视虚拟化技术的创新,为确保用户网络共享的安全奠定基础。
4.3实现虚拟局域网的交叠
VLAN技术改变了过去一个交换机对应一个VLAN的缺点。可以实现一个交换机对应多个VLAN,可以实现临时VLAN和突发VLAN的划分。例如,大企业的部门制度也比较复杂。在组建响应团队时,应从每个独立的虚拟局域网部门中选择几名成员。在这一过程中,必须确保团体之间以及成员与原部门之间的沟通自由。这种重叠技术可以灵活地安排企业中的人员沟通。为提高人员沟通效率,需设置临时人员对应的交换机端口。
5  局域网组建策略模型的分析与实现
5.1用户需求分析
企业办公楼内部网络作为重要的办公资源,为企业提供办公自动化,计算机管理,资源共享和信息交流等全方位服务。目前,假设有动物园的信息点,它们将来可能会扩大。企业的许多工作依赖于网络,这就要求网络的性能满足高效办公的要求。同时,网络的可靠性也很高,这就要求网络不能在办公时间关闭。因此,在网络设计过程中应充分考虑网络设备的可靠性。同时,对网络设备和线路应考虑冗余备份,单点故障引起的整个网络故障不应影响企业的正常运行。企业需要通过专线接入外部网络。
5.2整体设计方案
根据用户的需求,我们需要为用户提供解决方案。首先,根据用户的高可靠性,高性能和可扩展性的需求和资金预算,考虑用户的需求以及使用哪种网络结构。二,选择合适的设备,模块和电缆。在网络设计中,应充分考虑网络的可靠性和可扩展性,以便在未来用户信息点数量增加后,可以增加少量设备以满足用户的需求。
5.2.1拓扑图
根据用户对可靠性的要求,将网络设计为双核结构。为了保证高性能,采用双芯进行负载分担。当其中一个核心交换机出现故障时,可将数据传输到另一个交换机,起到冗余备份的作用。如图4所示。
 
图4  “双核心”结构网络拓扑图
5.2.2VLAN划分
根据用户的需求,在整个网络内划分10个VLAN(根据实际情况,按照部门划分VLAN,目的是为了控制广播的流量,并实现一定的安全性,本论文以10个VLAN为例)。VLAN ID为2-11,VLAN 1为管理VLAN。
5.2.3端口规划
(1)核心三层交换机的端口分配
两台三层交换机的f0/1和f0/2接口配置EthernetChannel,连接方式为Trunk。端口f0/10一19用来连接接入层的二层交换机,配置为Trunko SW-3L-1的端口24连接路由器,配置为路由接口。
(2)接入层二层交换机的端口分配
端口f0/23:24用来连接三层交换机,配置为Trunk链路。端口f0/10 20用来连接主机。
5.2.4VTP配置
(1)VTP域名为hnzy
(2)密码为123
(3)启用修剪
(4)配置2台三层交换机为Serve:模式,并在SW-3L-1上添加VLAN
(5)配置全部的二层交换机为VTP的Client模式,将端口添加到相应的VLAN中。
SW一3L-1#vlan data
SW-3L-1(vlan)#vtp server
Device mode already VTP SERVER.
SW-3L-1(vlan)#vtp domain hnzy
Changing VTP domain name from NULL to hnzy
SW-3L-1(vlan)#vtp password 123
Setting device VLAN database password to 123.
SW-3L-1(vlan)#vtp pruning
Pruning switched ON
SW-3L-1(vlan)#vlan 2
VLAN 2 added:
Name:VLAN0002
SW-3L-1(vlan)#vlan 11
VLAN 11 added:
Name:VLAN0011
SW一3L-2#vlan database
SW-3L-2(vlan)#vtp server
Device mode already VTP SERVER.
SW-3L-2(vlan)#vtp domain hnzy
Changing VTP domain name from NULL to hnzy
SW-3L-2(vlan)#vtp password 123
Setting device VLAN database password to 123.
SW-3L-2(vlan)#vtp pruning
Pruning switched ON
SW-2L-1#vlan database
SW-2L-1(vlan)#vtp domain hnzy
Changing VTP domain name from NULL to hnzy
SW-2L-1(vlan)#vtp client
Setting device to VTP CLIENT mode.
SW-2L-1(vlan)#vtp password 123
Setting device VLAN database password to 123.
其他交换机配置类似
SW-2L-1(config)#interface range f0/1一10
SW-2L-1(config-if-range)#switchport access vlan 2
SW-2L-1(config)#interface range f0/11-20
SW-2L-1(config-if-range)#switchport access vlan 3
其他交换机配置类似
5.2.5STP配置
(1)设置SW-3L-1是VLAN26的生成树根网桥
(2)设置S W-3 L-2是VLAN711的生成树根网桥
SW-3L-1(config)#spanning-tree vlan 2 root primary
SW-3L-1(config)#spanning-tree vlan 3 root primary
SW-3L-1(config)#spanning-tree vlan 4 root primary
SW-3L-1(config)#spanning-tree vlan 5 root primary
SW-3L-1(config)#spanning-tree vlan 6 root primary
SW-3L-1(config)#spanning-tree vlan 7 root secondary
SW-3L-1(config)#spanning-tree vlan 8 root secondary
SW-3L-1(config)#spanning-tree vlan 9 root secondary
SW-3L-1(config)#spanning-tree vlan 10 root secondary
SW-3L-1(config)#spanning-tree vlan 11 root secondary
SW-3L-2(config)#spanning-tree vlan 2 root secondary
SW-3L-2(config)#spanning-tree vlan 3 root secondary
SW-3L-2(config)#spanning-tree vlan 4 root secondary
SW-3L-2(config)#spanning-tree vlan 5 root secondary
SW-3L-2(config)#spanning-tree vlan 6 root secondary
SW-3L-2(config)#spanning-tree vlan 7 root primary
SW-3L-2(config)#spanning-tree vlan 8 root primary
SW-3L-2(config)#spanning-tree vlan 9 root primary
SW-3L-2(config)#spanning-tree vlan 10 root primary
SW-3L-2(config)#spanning-tree vlan 11 root primary
5.2.6三层交换机的配置
(1)在三层交换机上配置各VLAN的IP地址,SW-3L-1配置两个网关地址中较小的IP地址:
(2)配置两台三层交换机之间的EthernetChannel
(3)配置三层交换机的路由接口
(4)在三层交换机上配置RIP路由协议
SW-3L-1(config)#ip routing
SW-3L-1(config)#interface vlan 2
SW-3L-1(config-if)#ip address 192.168.10.1 255.255.255.192
其他VLAN的IP地址配置方法相同
SW-3L-2(config)#ip routing
SW-3L-2(config)#interface vlan 2
SW-3L-2(config-if)#ip address 192.168.10.2 255.255.255.192
其他VLAN的IP地址配置方法相同
SW一3L-1#conf t
Enter configuration commands,one per line.End with CNTL/Z.
SW-3L-1(config)#interface range f0/1-2
SW-3L-1(config-if-range)#channel-group 1 mode on
Creating a port-channel interface Port-channell
SW一3L-2#conf t
Enter configuration commands,one per line.End with CNTL/Z.
SW-3L-2(config)#interface range f0/1-2
SW-3L-2(config-if-range)#channel-group 1 mode on
Creating a port-channel interface Port-channell
SW-3L-1(config)#router rip
SW-3L-1(config-muter)#network 192.168.10.0
SW-3L-1(config-muter)#network 192.168.20.0
SW-3L-1(config-muter)#network 192.168.30.0
SW-3L-1(config-muter)#network 172.16.0.0
S W-3 L-1(config-muter)#exit
SW-3L-1(config)#ip route 0.0.0.0 0.0.0.0 172.16.1.2
SW-3L-2(config)#router rip
SW-3L-2(config-muter)#network 192.168.10.0
SW-3L-2(config-muter)#network 192.168.20.0
SW-3L-2(config-muter)#network 192.168.30.0
SW-3L-2(config-muter)#network 172.16.0.0
SW-3L-2(config-muter)#exit
SW-3L-2(config)#ip route 0.0.0.0 0.0.0.0 172.16.1.2
5.2.7路由器的配置
路由器的配置参数如下:
(1)配置路由器接口的IP地址
(2)配置路由器启动RIP路由协议
(3)配置路由器上的默认路由,指向10.1.1.1/24
Router(config)#router rip
Router(config-muter)#network 172.16.0.0
Router(config-muter)#network 10.0.0.0
Router(config)#ip route 0.0.0.0 0.0.0.0 10.1.1.1
5.3系统测试
配置完成后,需要进行测试,验证配置是否正确,是否能满足企业需求。测试工具(见表1)。
表1  主要测试工具
 
5.3.1测试内容
交换机测试:检查同一VLAN和不同VLAN的VLAN状态,地址解析表,联机主机连通性,中继端口是否可以转发所有VLAN,检查各交换机的VLAN信息,验证VLAN学习是否正确,检查交换机上的STP信息,验证STP根桥是否正确,长时间ping主机时断开上行链路,验证数据共享是否已加载,检查VTP配置信息等。
路由器测试:测试路由表是否生成正确,显示全局接口地址状态,断开连接,观察路由表的变化。查看接口、默认路由、动态路由配置等。
5.3.2测试方法
根据设计方案中的方案,检查网络设备是否正确连接,相关电缆是否正确识别。根据拓扑图的划分,连接网络拓扑,结合VLAN,IP和路由规划,利用测试笔记本通过控制台端口连接到相应的网络设备,对系统进行测试。
交换测试:使用显示运行和显示VLAN命令检查网络设备的IP和VLAN配置是否符合设计计划。在同一个VLAN中,ping不同端口,测试流量是否正常。断开VLAN间的路由,通过ping测试多个VLAN间的通信。恢复VLAN间的路由,用ping命令测试,用showMAC地址表命令检查MAC地址表,验证交换机是否可以学习MAC地址,用showVTP状态命令查看VTP配置信息和VTP通知信息,查看配置信息。显示生成树简短命令的生成树。
路由器测试:通过Ping检查网络设备的接口地址,显示IP接口命令,通过Ping命令检查各网段的互通情况,通过showip路由命令检查路由表,通过traceroute检查相关主机地址,检查路由是否与拓扑图一致等。
5.3.3测试结果
所有设备稳定,运行正常。所有设备之间的连接应稳定和稳定。满足功能设计要求。
6  总结
从这个角度看,虚拟局域网络的建立和应用对计算机技术的创新具有重要意义。计算机虚拟局域网技术的发展给人们的生活和工作带来了方便。根据用户的不同需求,进行VLAN技术创新。用户可以根据自己的需要选择VLAN的建立方法,促进计算机网络之间的信息交换。计算机虚拟局域网(VLAN)的发展不仅给人们的网络通信带来了安全性,而且大大提高了局域网的网络通信速度。然而,应不断改革和发展计算机虚拟局域网络技术,以适应时代的步伐,为我国计算机网络通信做出贡献,促进计算机网络的发展。
 
参考文献
[1]唐琦,齐齐哈尔工程学院.无线局域网组建与应用[J].企业文化旬刊,2016,2013(8):183-183.
[2]杨昊凡,郑元元.家庭无线局域网的组建[J].中国教育技术装备,2011(23):40-41.
[3]刘静.局域网组建与管理[M].对外经济贸易大学出版社,2011.
[4]陈晓桢,CHENXiao-zhen.光纤局域网的组建与应用技术[J].中国有线电视,2010(2):159-161.
[5]付磊,陈林,王洪艳.有线局域网的组建及应用维护[J].信息与电脑(理论版),2010(6):74-74.
[6]陈洪彬.局域网组建与维护[M].兵器工业出版社北京希望电子出版社,2010.
[7]石良武.计算机网络与应用[M].清华大学出版社,2011.
[8]王伟.机房局域网组建方法研究[J].软件,2012,33(3):94-95.
[9]岳龚成.计算机局域网的组建与管理[J].电脑编程技巧与维护,2017(3):64-66.
[10]易甲富.企业局域网组建过程中WLAN技术的应用[J].电脑知识与技术,2014(20):4714-4715.
重要提示:转载本站信息须注明来源:985论文网,具体权责及声明请参阅网站声明。
阅读提示:请自行判断信息的真实性及观点的正误,本站概不负责。
jQuery右侧可隐藏在线QQ客服